Upgrade

Instructions to upgrade Melete 2.9.5 to Melete 2.9.9 for Sakai 10.1.

1. Get the Source
2. Sferyx Editor
3. Internationalize Messages (Optional)
4. Compile and Deploy  
5. Questions?


1. Get the Source

Download the etudes-util and ltiContact (dependencies of Melete) and Melete software from SVN into your Sakai 10.1 source folder 

sakai> svn co https://source.sakaiproject.org/contrib/etudes/etudes-util/tags/1.0.25/ etudes-util

sakai> svn co https://source.sakaiproject.org/contrib/etudes/ltiContact/tags/1.2/ ltiContact

sakai> svn co https://source.sakaiproject.org/contrib/etudes/melete/tags/2.9.9 melete  

2. Sferyx Editor

If you are using Sferyx with Melete then you have to upgrade Sferyx Applet. Melete 2.9.9 needs Sferyx 10.2 or higher version. Sferyx has introduced posting contents in AJAX style and Melete is using it.

3. Internationalize Messages (Optional)

If you want to run Melete in a different language than English, you need to update messages.properties of your language under melete-app/src/bundle and under melete-impl/src/bundle.

4. Compile and Deploy

4.1. Code Change for Oracle Users ONLY

The Melete code uses the “straight_join” keyword for query optimization with a Mysql join. Oracle does not support this keyword. Please remove this keyword from melete/melete-impl/src/java/org/etudes/component/app/melete/ModuleDB.java.

4.2 Update the Sakai base pom.xml

Add lines to the Sakai root pom.xml build profile section that you are using (the default is the “full” profile). These instruct Maven to include the Melete sources in the build. <module>etudes-util</module> <module>melete</module> Without this, full builds of the source will skip Melete.

4.3 Update the Sakai master pom.xml

Add lines to the Sakai master/pom.xml properties and dependency management section for the Etudes artifacts. 

a. Properties: add to the <properties> section: 

<etudes.util.version>1.0.25</etudes.util.version>
<lticontact.version>1.2</lticontact.version>
<melete.version>2.9.9</melete.version>  

b. Dependencies: add to the <dependencyManagement><dependencies> section: 

<dependency>
<groupId>org.etudes</groupId>
<artifactId>etudes-util-api</artifactId>
<version>${etudes.util.version}</version>
<scope>provided</scope>
</dependency> 

<dependency>
<groupId>org.etudes</groupId>
<artifactId>etudes-util-util</artifactId>
<version>${etudes.util.version}</version>
</dependency>

<dependency>
<groupId>org.etudes</groupId>
<artifactId>etudes-lticontact-util</artifactId>
<version>${lticontact.version}</version>
</dependency>

<dependency>
<groupId>org.etudes</groupId>
<artifactId>etudes-melete-api</artifactId>
<version>${melete.version}</version>
<scope>provided</scope>
</dependency>  

Note: This version is configured to build with Sakai 10.1. If you are using another version, you need to make a few changes. 

The “10.1” version number is in a few files, used as the version number for the Sakai base pom. You need to edit these files to change this to match the version of Sakai you are using: 

etudes-util/pom.xml
ltiContact/pom.xml
 melete/pom.xml 

4.4 Run maven commands

Build your sakai including etudes-utilltiContact and Melete. When you use maven to build sakai, it will include the sources needed for Melete

5. Questions?

Contact sakai-dev@collab.sakaiproject.org or dev@etudes.org

 

Print Friendly, PDF & Email